AYUDA Reparar disco duro con sectores dañados dividido en 2 discos

eidosc

Master Chapuzas
Registrado
12 Mar 2016
Mensajes
118
Puntos
28
Hola compañeros,

a ver si me podéis echar una mano que tengo un disco duro de 3TB que me está dando la lata...

Se trata de un WD red de 3TB que tengo en una NAS, lo tengo desde hace sólo unos 4 días (me lo dieron así)y tiene relativamente poco uso... En la NAS aparentemente va bien y no detecta ningún error, pero cuando empiezo a copiar datos simplemente falla el volumen.

Lo conecto a windows y me aparece esto (os pongo capturas del administrador de dispositivos y del crystaldisk) el disco me aparece con sectores dañados y windows me lo reconoce como 2 discos. Lo he probado en un ordenador con windows 8.1 y en otro con XP y en ambos me pasa lo mismo, comentar que lo tengo conectado al PC a través de una carcasa para discos duros de 3,5" un tanto antigua, es usb 2.0


Y0mNMK7.jpg


kCuFxCS.jpg



He intentado arreglarlo con el Hiren´s Boot (HDAT2 4.9B1 test repair bad sectors) siguiendo tutoriales, pero me dice lo siguiente: "HDAT2 Load error: no DPMI - Get csdpmi*b.zip" y no me detecta el disco (o al menos yo no consigo hacerlo funcionar)
También he visto este tutorial para el testdisk http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step he empezado a hacerlo pero me tarda la vida y quería consultar con vosotros qué hacer antes de ponerme con eso.

Un saludo y gracias!!
 
Última edición:

Annubis

Capitaaaan cavernicolaaaa
Miembro del equipo
Registrado
2 Sep 2013
Mensajes
9.638
Puntos
113
TestDisk no es para eso, es para intentar reparar particiones dañadas o recuperar datos de un disco duro dañado. ¿O quieres recuperar la información que hay en el disco?
Mejor usa HDD regenerator para lo que quieres hacer.
 

eidosc

Master Chapuzas
Registrado
12 Mar 2016
Mensajes
118
Puntos
28
Muchas gracias, probaré con HDD regenerator.

No, no tiene datos, simplemente querría recuperar esos sectores para que funcionase sin fallos, pero eso si, usarlo como disco secundario y para cosas no importantes...

Una duda, es normal que me salga en el administrador de dispositivos de windows dividido en 2 discos??
 

elratonperez

Master Chapuzas
Registrado
23 Jun 2015
Mensajes
380
Puntos
43
Aparte del sector pendiente que debería corregirse tras un formateo "lento" desde el propio Windows, puedes tener un problema con la capacidad del disco al ser mayor de 2TB. Discos tan grandes suelen ser un dolor de cabeza en equipos antiguos.
 

Annubis

Capitaaaan cavernicolaaaa
Miembro del equipo
Registrado
2 Sep 2013
Mensajes
9.638
Puntos
113
Aparte del sector pendiente que debería corregirse tras un formateo "lento" desde el propio Windows, puedes tener un problema con la capacidad del disco al ser mayor de 2TB. Discos tan grandes suelen ser un dolor de cabeza en equipos antiguos.

A no ser que la placa esté limitada, con formatearlo con una tabla de particiones GPT, sería suficiente.

No me acordaba. Seguramente Windows te lo detecta así porque está con una tabla de particiones MBR y ésta tiene una limitación de 2TB para los discos duros.
 

eidosc

Master Chapuzas
Registrado
12 Mar 2016
Mensajes
118
Puntos
28
Muchas gracias,

pues esto está en marcha con el hdd regenerator, he empezado por el trozo de disco de 2048GB...

A ver si me quedó claro:

- Escanear y reparar parte 01 con hdd regenerator (aprox. 2000GB)
- Escanear y reparar parte 02 (aprox. 750GB)
- Formato completo con windows con tabla de particiones GPT parte 01
- Formato completo con windows con tabla de particiones GPT parte 02 (no tengo claro que para este paso la parte 02 siga existiendo)

Es correcto?? El disco va a volver a la NAS, donde tendrá una jubilación dorada como almacenamiento de películas y series...no sé si influye en algo para eso lo de la tabla de particiones al no ser windows...

Un saludo!!
 

elratonperez

Master Chapuzas
Registrado
23 Jun 2015
Mensajes
380
Puntos
43
A ver que pasa con ese sector defectuoso. Si desaparece con HDD regenerator no pierdas el tiempo formateando con el PC, instala el disco nuevamente en el NAS y dale formato desde ahí dejando una única partición.
 

eidosc

Master Chapuzas
Registrado
12 Mar 2016
Mensajes
118
Puntos
28
entendido, gracias!!

esto va con la calma....2,95% pero de momento va bien 97 bad sectors recovered...a ver como queda...cuando termine os cuento!!

gracias por guiarme que estaba dando palos de ciego sin saber hacia donde ir!!
 

KY_WD

Master Chapuzas
Registrado
30 Jul 2014
Mensajes
125
Puntos
0
¡Hola a todos!
eidosc, ¿además el programa mencionada por Annubis has comprobado el disco duro WD Red con la herramienta WD Data Lifeguard Diagnostics? Si no, te recomiendo hacerlo y vínculo para descargar nuestro programa gratis está aquí: http://products.wdc.com/support/kb.ashx?id=3uhF39 Hay que hacer el test extendido.
Me interesa también saber si has intentado de conectar el disco duro directamente a tu equipo en las ranuras de SATA, es decir - sin la carcasa.
Si no tienes una información importante, te recomiendo ejecutar la opción de WRITE ZEROS para borrar a bajo nivel tu unidad de WD.
Por favor, regresa con una información después.

Saludos.
 

eidosc

Master Chapuzas
Registrado
12 Mar 2016
Mensajes
118
Puntos
28
Hola KY_WD,

gracias por la ayuda, estoy ahora analizando el disco con el hdd regenerator (lleva más de 20 horas) pero descargo el WD Data Liveguard, y lo analizaré con este programa también, no tengo información en el disco, así que le puedo hacer cualquier cosa.

Supongo que conectarlo directamente a un puerto sata es lo ideal, pero no tengo ningún equipo de sobremesa disponible ahora mismo, por eso la carcasa externa.

Cuando termine todo os comentaré (de momento parece que va bien el proceso ya que me está recuperando todos los bad sectors que detecta), pero va para largo, que los análisis van muy lento.

Un saludo!!
 

Annubis

Capitaaaan cavernicolaaaa
Miembro del equipo
Registrado
2 Sep 2013
Mensajes
9.638
Puntos
113
Hola KY_WD,

gracias por la ayuda, estoy ahora analizando el disco con el hdd regenerator (lleva más de 20 horas) pero descargo el WD Data Liveguard, y lo analizaré con este programa también, no tengo información en el disco, así que le puedo hacer cualquier cosa.

Supongo que conectarlo directamente a un puerto sata es lo ideal, pero no tengo ningún equipo de sobremesa disponible ahora mismo, por eso la carcasa externa.

Cuando termine todo os comentaré (de momento parece que va bien el proceso ya que me está recuperando todos los bad sectors que detecta), pero va para largo, que los análisis van muy lento.

Un saludo!!
¿Cómo ha ido? ¿Solucionado?

Trocotroleado con mi Movilote
 

KY_WD

Master Chapuzas
Registrado
30 Jul 2014
Mensajes
125
Puntos
0
Hola KY_WD,

gracias por la ayuda, estoy ahora analizando el disco con el hdd regenerator (lleva más de 20 horas) pero descargo el WD Data Liveguard, y lo analizaré con este programa también, no tengo información en el disco, así que le puedo hacer cualquier cosa.

Supongo que conectarlo directamente a un puerto sata es lo ideal, pero no tengo ningún equipo de sobremesa disponible ahora mismo, por eso la carcasa externa.

Cuando termine todo os comentaré (de momento parece que va bien el proceso ya que me está recuperando todos los bad sectors que detecta), pero va para largo, que los análisis van muy lento.

Un saludo!!

¡Olvidé avisarte! Por favor, quita el numero de serie del printscreen del Crystal Disk para evitar abuso.
Comentános lo que sucede.

Saludos.
 

eidosc

Master Chapuzas
Registrado
12 Mar 2016
Mensajes
118
Puntos
28
Hola compañeros!

No me había olvidado de vosotros, pero es que esto tardó una vida!!!

Os cuento lo que hice, que al final fue una especie de remix....

1) Primero pasé el HDD regenerator. El resultado fue (después de unas 26 horas):

20 delays detected
0 sectors remain bad
97 sectors recovered
0 new bad sectors appear
0 bad sectors reappear​

2) Pero al pasarle el Crytal Disk info me seguían apareciendo errores y estado aparecía "en riesgo" (se me olvidó hacer captura, perdón)

3) Así que pasé el Extended Test con el WD Data Lifeguard Diagnostics, el cual aparentemente pasó el test completo (otras 20 horas) pero me dio el siguiente error al terminar

08-Too many bad sectors detected.​

4) Finalmente ya metidos en harina usé la opción de Write Zeros también del WD Data Lifeguard Diagnostics (unas 28 horas) el cual aparentemente terminó bien.

Test Option: QUICK TEST
Model Number: WDC WD30EFRX-68EUZN0
Unit Serial Number:
Firmware Number: 82.00A82
Capacity: 2199.02 GB
SMART Status: PASS
Test Result: PASS
Test Time: 23:58:27, May 11, 2016
Test Option: EXTENDED TEST
Model Number: WDC WD30EFRX-68EUZN0
Unit Serial Number:
Firmware Number: 82.00A82
Capacity: 2199.02 GB
SMART Status: PASS
Test Result: FAIL
Test Error Code: 08-Too many bad sectors detected.
Test Time: 20:10:36, May 12, 2016
Test Option: WRITE ZEROS
Model Number: WDC WD30EFRX-68EUZN0
Unit Serial Number:
Firmware Number: 82.00A82
Capacity: 2199.02 GB
SMART Status: PASS
Test Result: COMPLETE
Test Time: 21:30:51, May 13, 2016​

5) Al abrirlo con el administrador de equipos de windows me pidió que eligiese un tipo de partición y seleccioné GPT

6) Vuelta a analizar con el Crystal Disk y esta vez me dice estado de salud: Bueno (yuhu!!). Este es el resultado:

Cm8VWhI.jpg


7) Ahora me lo llevaré de vuelta a la NAS a ver que tal, pero tiene buena pinta no??

Muchas gracias a todos por la ayuda, esperemos que no vuelva a fallar si no como diría Freddy Krueger...volveré!!!

P.D.01 Números de serie editados, gracias por el aviso.
P.D.02 Gracias de nuevo a todos KY_WD, Annubis, elratonperez unos cracks!!
 
Última edición:

elratonperez

Master Chapuzas
Registrado
23 Jun 2015
Mensajes
380
Puntos
43
Me alegro de que todo haya salido bien. Durante los próximos días debes vigilar que no aparezcan nuevos sectores defectuosos. Por ejemplo en los NAS Synology se les puede programar para que hagan una prueba SMART de forma periódica.
 

eidosc

Master Chapuzas
Registrado
12 Mar 2016
Mensajes
118
Puntos
28
Agh!!

Ha vuelto a fallar en la NAS, la dejé por la noche copiando datos y no terminó la tarea, falló y me dice que se han encontrado "bad sectors"...

Por la noche o mañana conecto el disco al pc a ver que me dice Crystal Disk y os lo pongo que ahora no puedo...

Un saludo!!
 

KY_WD

Master Chapuzas
Registrado
30 Jul 2014
Mensajes
125
Puntos
0
¡Hola!

Lamentablemente, cuando aparece el error 08 /de demasiados sectores malos detectados/ eso significa que el disco duro está en el punto de fallar. Por otra parte, el Crystal Disk no marca errores /de lo que puedo ver de la pantalla por arriba/. Pues, el caso es muy raro.
De todos modos, te recomiendo ponerte en contacto con nuestros colegas tras abriendo un ticket en el sistema de Soporte mediante haciendo un click aquí: http://products.wdc.com/support/kb.ashx?id=FlmAVX

¡Saludos y suerte!
 

eidosc

Master Chapuzas
Registrado
12 Mar 2016
Mensajes
118
Puntos
28
Hola a todos,

Este es el nuevo informe del Crystal Disk después de que me haya dado fallo en la NAS:
pLgt3gB.jpg


Es posible que haya hecho una cosa mal, como comentaba más arriba, en windows me aparece el disco dividido en 2 unidades, y solo he usado la opción de Write Zeros en una de las partes (ya que pensaba que al hacerla en una parte lo haría en todo). Voy a probar usar la opción Write Zeros en ambas...a ver que pasa....

Gracias por el link de soporte KY_WD, a ver si consigo algo por ahí si lo anterior no funciona.

Un saludo!!
 

KY_WD

Master Chapuzas
Registrado
30 Jul 2014
Mensajes
125
Puntos
0
Puede que la "caja" del NAS tenga fallos pero no olvides que la opción Write Zero va a limpiar el disco por completo. :)
 

tec-ray

Chapuzas Jr
Registrado
23 Jul 2015
Mensajes
23
Puntos
0
Como te han dicho antes, crea una sola partición con GPT; no sigas manteniendo dos.
 
Arriba