VPN funciona a medias

juanpeich

Nuevo
Registrado
13 May 2021
Mensajes
2
Puntos
1
Edad
35
Buenas noches a todos. A ver si me podéis echar una mano que no se dónde estoy metiendo la pata.

Tengo 2 locales. En uno Vodafone y en otro Jazztel.
En el local 1 tengo un ordenador dentro y otro en la caja además de la Raspberry Pi 4 que hace de servidor VPN.
En el local 2 tengo un ordenador dentro y otro en caja.

Conseguí poner en funcionamiento OpenVPN, pero viendo que el programa de gestión ib algo lento, me decidí a cambiar a wireGuard, eligiendo el puerto que aconsejan 51820 y las DNS de Google.

Tras instalarlo en la Raspberry a través de piVPN, y los clientes en los ordenadores, ahora sucede que desde el local 2 solo hace ping y ve los ordenadores del local 1 si pongo la IP virtual (10.6.0...), sin embargo si por ejemplo me conecto desde mi casa a la VPN con el portátil, mediante el cliente wireGuard, si que hace ping a la IP local 192.168.0.... del local 1.

El problema creo que está en el local 2, pero no de dónde. De hecho, si me conecto a la VPN desde los ordenadores del local 2, ya no me deja ni acceder al router del local 2 (192.168.0.101. le puse este por diferenciarlo del router del local 2, que es 192.168.0.1).

Me está dando muchos quebraderos de cabeza, cuando yo pensaba que solo era sustituir OPENVPN por wireGuard, pero no ha resultado ser así.


Podríais echarme una mano?


Muchas gracias de antemano por todo

Un saludo,
JuamPe
 

RetroBixo

Comecocos Interdimensional
Registrado
4 Oct 2019
Mensajes
2.131
Puntos
113
Se me ocurre que en el momento en el que te conectas por Wireguard tienes dos redes diferentes con el mismo rango de IPs 192.168.0.x.

Prueba con otra subred en el local 2, 192.168.1.x o 10.10.0.x.
 

juanpeich

Nuevo
Registrado
13 May 2021
Mensajes
2
Puntos
1
Edad
35
Se me ocurre que en el momento en el que te conectas por Wireguard tienes dos redes diferentes con el mismo rango de IPs 192.168.0.x.

Prueba con otra subred en el local 2, 192.168.1.x o 10.10.0.x.
Ok, probaré a ver. Yo que tenía pensado que para que fuera más fácil y que pudieran verse entre ellos, debería tener la misma subred de 192.168.0...., por eso cambié los rangos de IPs.

Para que no entraran en conflicto entre ellos, lo que hice fue asignarles a todos los ordenadores ip estáticas, de manera que los del local 1 estuviera a partir del 192.168.0.11, y los del local 2 a partir de 192.168.0.21
 

RetroBixo

Comecocos Interdimensional
Registrado
4 Oct 2019
Mensajes
2.131
Puntos
113
Ok, probaré a ver. Yo que tenía pensado que para que fuera más fácil y que pudieran verse entre ellos, debería tener la misma subred de 192.168.0...., por eso cambié los rangos de IPs.

Para que no entraran en conflicto entre ellos, lo que hice fue asignarles a todos los ordenadores ip estáticas, de manera que los del local 1 estuviera a partir del 192.168.0.11, y los del local 2 a partir de 192.168.0.21

Pero así cuando a un equipo del local 2 se conecta a la VPN todas las 192.168.0.x van por ella y dejas de acceder a las locales.

Separándolas, al conectar el equipo tendrá dos IPs, una en el rango del local 1 y otra propia dentro rango independiente para el local 2.
 

Litus81

Chapuzas Jr
Registrado
3 Oct 2018
Mensajes
25
Puntos
3
Yo estoy teniendo un problema similar al usar un VPN por protocolo L2TP a través de un NAS de Synology. Abro los puertos en el router de Lowi, pero cuando los chequeo en internet, me salen que están cerrados y no lo entiendo. Consigo configurar el VPN, pero cuando realizo pruebas de velocidad, mi subida pasa de 300 Mbps a 80 Mbps como mucho. La verdad que no se donde puede estar el fallo.

Si intento conectar la vpn a través de mi cuenta de synology me da error, pero si meto la ip del NAS se conecta, pero con estos fallos de conexión. A ver si alguien puede darme algo de luz. También he de decir que siguiendo los tutoriales encontrados por YT, a lo que la gente le sale en verde y OK (dhcp, entorno de red, etc) a mi me sale todo al contrario. Tengo sospechas de que puede ser la mierda de router de Lowi el que esté jodiendo la marrana. Muchas gracias de antemano.
Salu2.
 
Arriba