AYUDA programacion de base de datos con VBA EXCEL

peta93

Nuevo
Registrado
4 May 2020
Mensajes
3
Puntos
0
Hola a todos,
Antes de nada decir que soy nuevo por aqui, desconozco si este tema es adecuado en este sub foro. pero si alguien me puede ayudar estaria eternamente agradecido. estoy investigando en excel para hacerme un programa basico de gestion de cuentas para mis proyectos, numeros de inversiones, beneficios, tiempo etc.

la cuestion es que tengo ya programado el registro de los datos, pero me encuentro atascado en la programacion de la busqueda de datos. de ahi y por la recomendacion de un amigo, acudo a este foro.


partimos de la base de que jamas he dado nada ni visto nada ni tengo nivel de programacion alguno, simplemente me guio por los tutoriales de youtube, pero concretamente lo que necesito hacer para la busqueda no lo encuentro ahi.


alguien que domine este tema y pueda ayudarme??? gracias!!
 

kakadeluxe

Master Chapuzas
Registrado
9 Mar 2018
Mensajes
2.501
Puntos
113
Edad
56
¿Donde esta los datos?, ¿En una base de datos externa o en una de las tablas del Excel?.
 

peta93

Nuevo
Registrado
4 May 2020
Mensajes
3
Puntos
0
En una tabla en otra hoja de excel
 

peta93

Nuevo
Registrado
4 May 2020
Mensajes
3
Puntos
0
Es preferible una bd externa o una creada en excel si es que esta bien definido de este modo..?
Tengo video de lo que he creado y hasta donde he llegado, puedo subir fotos de lo que tengo y intentar explicar que paso quiero dar a continuacion.
pero basicamente he creado unos wordArt a los cuales les he asignado macros para introducir datos en diferentes tablas, el problema esta a la hora de crear macros para buscar esos datos en base a los criterios que quiero, que serian dos criterios solamente, pero como digo no se programacion ni encuentro en tutoriales el codigo adecuado para las acciones que necesito que realicen mis tablas, hojas etc
 

kakadeluxe

Master Chapuzas
Registrado
9 Mar 2018
Mensajes
2.501
Puntos
113
Edad
56
Usa BUSCARV para encontrar el dato en otra hoja de Excel. Por Internet tienes miles de ejemplos.
=BUSCARV(A2;'C:\Users\tunombredeusuario\Documents\loquesea\[Libro2.xlsx]Hoja1'!$A$1:$D$8;2;FALSO)

Usar VBA sin conocerlo es un reto muy grande para ti, hay mucho codigo por Internet pero no creo que sepas adaptarlo a tus necesidades.

Los datos externos es mejor tenerlos en una base de datos como MySQL o SQL Server, pero esto es mas factible de manejar, hay aplicaciones o frontend para manejo de esas bases de datos.
 
Arriba