SOLUCIONADO: Problemas con color azul muy específico en MSI Optix G241VC

Cerbumota

Chapuzas Jr
Registrado
16 Nov 2020
Mensajes
29
Puntos
3
Edad
50
Buenas.
Esta historia me está pudiendo. A ver si tengo suerte, y se os ocurre a vosotros alguna cosa, porque ni MSI ni Microsoft dan soluciones... válidas. (Darlas, las dan mucho y a cada cual más torpe.) Os cuento.
De antemano, mi ordenador tiene una gráfica RX590 Nitro+ de Sapphire

Tengo dos monitores de 24': un Samsung de 144Mhz (C24FG7xFQ por DP) y un MSI Optix G241VC de 75 Mhz por HDMI. El Samsung es el principal, y más viejo. Ha ido siempre bien, salvo unos pequeños problemas en el arranque, cuando el monitor está frío, donde aparecen las rayas distorsionadas y de colores que no nos suelen gustar. Pero la tienda dice que a ellos les va perfectamente, por lo que me mandan... a la porra.
El segundo, el MSI, y que es por lo que os consulto, va bien. Excepto la tontería que el color azul lo veo violeta... pero sólo en mi ordenador. Añadiéndolo a un portátil, con gráfica Intel HD, los colores se ven perfectamente. Consulté a MSI por el problema, y otros que se lavaron las manos: me insistieron que cargara los drivers suyos... cosa que obviamente, ya había hecho.
Lo arreglé una temporada. Creo que fué cambiando el esquema de color, eliminando toda configuración referente a MSI y a Samsung. Y creo, que también eliminé el driver de MSI y dejé el genérico PnP de Windows. Fué hace bastante y no me acuerdo...

Resulta que ahora, una actualización de Windows 10 ha causado estragos en mi ordenador: a la mierda el bluetooth, y vuelve el color violeta al MSI. Esto no puede seguir así, pero esta vez no consigo eliminar el problema.

¿Se os ocurre, a parte de tirar el monitor y/o el ordenador por la ventana, que más puedo hacer?
Gracias de antemano. Un saludo.
 

Cerbumota

Chapuzas Jr
Registrado
16 Nov 2020
Mensajes
29
Puntos
3
Edad
50
Debe ser Windows 10... La actualización 2004, concrétamente. O una de las múltiples actualizaciones que me ha hecho Microsoft desde que la puse. He arrancado con una versión anterior (1904) y se ve bien. He actualizado la misma versión de drivers de la tarjeta gráfica en ambas versiones, por lo que descarto problemas de gráfica.

En fin. Luego que diga alguien que Windows 10 es la estrella de Microsoft... Igual puedo opinar algo a eso. :ROFLMAO::ROFLMAO::ROFLMAO:
 

chetodann

Master Chapuzas
Registrado
27 Abr 2014
Mensajes
10.575
Puntos
113
Bueno, tienes un problema de perfil de color asignado a Windows de tu PC...

En el monitor que modo tienes? sRGB o estandard?... el resto de modos son insufribles (o muy mal calibrados, por no decir nada calibrado) en monitores Gaming.... reinicia los valores de fabrica del monitor (se pondrá por defecto el modo standard/sRGB, compruébalo), mira que en el panel AMD no tengas alguna corrección de color/contraste, modifica sólo el brillo en el monitor ... (y las opciones gaming que tenias)

Debes decirle a Windows como debe "leer" los colores .. Configuración Pantalla- > Config. Pantalla avanzada->Mostrar propiedades de ...-> Pestaña Administrador de color ->Administración color -> En dispositivos , selecciona la pantalla -> agregar -> selecciona sRGB IEC... o si tienes un perfil ICC de MSI (viene en los drivers, ese) ...como predeterminado. reinicia. W10.

nos cuentas...
 

Cerbumota

Chapuzas Jr
Registrado
16 Nov 2020
Mensajes
29
Puntos
3
Edad
50
Jajajajaja. Me he adelantado a eso. Ya he reiniciado los valores del monitor, he quitado las referencia de colores, las he vuelto a poner, he dejado los valores sRGB (en el administrador de color de Windows), he intentado configurarlo con las opciones del menú del monitor... y nada.

Me pasó otra vez, hacia Marzo. Nada más comprármelo. Y también me costó, haciendo lo que dices. De hecho, incluso abrí una incidencia a MSI indicando lo que pasaba. Ellos me dijeron, como te puedes suponer, que instalara los drivers de MSI. Cosa que ya había hecho. Y me mandaron los drivers... de un modelo igual al mío pero de 144Mhz. Según ellos, es el mismo.
De hecho, en Windows 7 siempre va bien. (Prueba con dos portátiles. No puedo decir las versiones...) Con el portátil de mi hija (W10, 1909) también va bien. Con el del trabajo, el mismo que el de mi hija, también va bien. Sin tocar nada. Con el mío, no. Y como digo, con la última actualización (KB4577266) se jorobó el bluetooth y el color.
Abrí incidencia a Microsoft por el bluetooth, ya que uso auriculares para video-llamadas. Y harto de poner, reponer, cambiar, recambiar, volver a puntos de restauración anteriores... Han sido totalmente incapaces de arreglarlo. De hecho, incluso me dieron una ISO que me reinstaló Windows 10. No quiero decir palabras malsonantes contra el servicio de atención al cliente de Microsoft, pero me parece una vergüenza su trabajo para lo que cobran por una licencia. (Me pasa por pedir la licencia original, cosa que hice cuando me monté el pc).

Que tengo un problema de color asignado a Windows, es obvio: con otros ordenadores, no pasa, por lo que puedo confirmar que problema físico del monitor no es. Pero es más. Si saco un pantallazo, con los colores azules distorsionados... ¡¡¡se ve bien en otro monitor/pc/móvil/sistema operativo!!! Que es de Windows, sí. Que es sólo con este monitor, también. El Samsung no muestra nada mal. Y también he quitado el perfil de Samsung de la lista de perfiles de color, por si era él el culpable. Tengo los de defecto de Windows...
 

kaelthass

Nuevo
Registrado
6 Ene 2021
Mensajes
2
Puntos
1
Edad
29
I have the same problem with my monitor, have you been able to find a solution? After doing some tests I am almost convinced that the problem is the incompatibility of the monitor and the AMD graphics control. Please if you have found a solution let me know.
 

kaelthass

Nuevo
Registrado
6 Ene 2021
Mensajes
2
Puntos
1
Edad
29
tengo el mismo problema con mi monitor, haz podido encontrar una solución? Yo después de hacer unas pruebas casi estoy convencido que el problema es la incompatibilidad del monitor y el controlar AMD de gráfica. Por favor si haz encontrado una solución avísame.
 

Litus81

Chapuzas Jr
Registrado
3 Oct 2018
Mensajes
22
Puntos
3
Jajajajaja. Me he adelantado a eso. Ya he reiniciado los valores del monitor, he quitado las referencia de colores, las he vuelto a poner, he dejado los valores sRGB (en el administrador de color de Windows), he intentado configurarlo con las opciones del menú del monitor... y nada.

Me pasó otra vez, hacia Marzo. Nada más comprármelo. Y también me costó, haciendo lo que dices. De hecho, incluso abrí una incidencia a MSI indicando lo que pasaba. Ellos me dijeron, como te puedes suponer, que instalara los drivers de MSI. Cosa que ya había hecho. Y me mandaron los drivers... de un modelo igual al mío pero de 144Mhz. Según ellos, es el mismo.
De hecho, en Windows 7 siempre va bien. (Prueba con dos portátiles. No puedo decir las versiones...) Con el portátil de mi hija (W10, 1909) también va bien. Con el del trabajo, el mismo que el de mi hija, también va bien. Sin tocar nada. Con el mío, no. Y como digo, con la última actualización (KB4577266) se jorobó el bluetooth y el color.
Abrí incidencia a Microsoft por el bluetooth, ya que uso auriculares para video-llamadas. Y harto de poner, reponer, cambiar, recambiar, volver a puntos de restauración anteriores... Han sido totalmente incapaces de arreglarlo. De hecho, incluso me dieron una ISO que me reinstaló Windows 10. No quiero decir palabras malsonantes contra el servicio de atención al cliente de Microsoft, pero me parece una vergüenza su trabajo para lo que cobran por una licencia. (Me pasa por pedir la licencia original, cosa que hice cuando me monté el pc).

Que tengo un problema de color asignado a Windows, es obvio: con otros ordenadores, no pasa, por lo que puedo confirmar que problema físico del monitor no es. Pero es más. Si saco un pantallazo, con los colores azules distorsionados... ¡¡¡se ve bien en otro monitor/pc/móvil/sistema operativo!!! Que es de Windows, sí. Que es sólo con este monitor, también. El Samsung no muestra nada mal. Y también he quitado el perfil de Samsung de la lista de perfiles de color, por si era él el culpable. Tengo los de defecto de Windows...
Pues con mi samsung ha sido exactamente lo mismo, ha sido instalar los drivers el otro día (perfil de color icc) y verse los azules como morados, y van a ir los tiros por donde dices, problemas de windows en su última update, porque antes de meter el perfil de color, no me pasaba, pero bueno en mi caso no es algo que moleste, es más, al tener problemas al ver colores muy vivos a raíz de una cirugía ocular, me viene hasta mejor.
Salu2.
 
Última edición:

Cerbumota

Chapuzas Jr
Registrado
16 Nov 2020
Mensajes
29
Puntos
3
Edad
50
Ayer me respondí con la solución, pero veo que se ha borrado por la recuperación del backup del foro. No pasa nada. Esas cosas ocurren en las mejores familias. Lo repito, aprovechando que ya contesté a un compañero por privado, para comentaros la solución.
Spoiler


Añadir que me he vuelto loco. Y que he probado muchas cosas. Y que ya no sé a quien echar la culpa del problema. Puede ser una actualización de Microsoft, que desde que se instaló, tengo el ordenador bastante inestable: el tema de red me va fatal; el audio tampoco, porque el micrófono que uso está un poco ronco (Fifinet T630); bluetooth no funciona y aunque detecta los dispositivos (casi todos audio), no es capaz de establecer conexión con ninguno (KB4577266). Puede ser una actualización de drivers de AMD. Puede ser el Dragon Center de MSI... Decir que he probado a actualizar TODO: chipset, bluetooth, wifi, bios, sonido, USBs, gráfica, utilidades de la gráfica (entre ellas, Dragon Center).
Y al final, con esta solución, ya tengo los colores azules como azules, y no violetas.
Estoy contento. Aunque ni el servicio técnico de la tienda, ni el de AMD, ni el de Microsoft, han ayudado para nada.
Un saludo
 
Arriba